Status
Help

Incident

Reporting and Analytics are down for Snowflake database merchants

Resolved | Jun 30, 2021 | 13:45 GMT-07:00

Snowflake has resolved the issue. Systems are operating normally.

Resolution in progress | Jun 30, 2021 | 12:48 GMT-07:00

Confirmed that Snowflake is working on a resolution to restore connectivity

Investigating | Jun 30, 2021 | 11:31 GMT-07:00

We are actively working with Snowflake to resolve the issue. You can get more information on how Snowflake is responding here: https://status.snowflake.com/

Status Page powered by Admin Labs